All Systems Operational

About This Site

Mambu - The Engine for Digital Banking

Mambu gives financial institutions a powerful competitive edge by allowing them to rapidly create, launch and service any lending portfolio through a flexible SaaS platform.

This is Mambu's status page for Mambu's multi-tenant environments hosted in the EU (Dublin, Ireland), US (Northern Virginia) and Asia Pacific (Sydney, Australia and Singapore)

Mambu Production (N. Virginia, USA):
Availability report last 30 days
Availability report current year

Mambu Production2 (N. Virginia, USA):
Availability report last 30 days
Availability report current year

Mambu Production (Dublin, Ireland)
Availability report last 30 days
Availability report current year

Mambu Production2 (Dublin, Ireland)
Availability report last 30 days
Availability report current year

Mambu Production (Singapore, Asia)
Availability report last 30 days
Availability report current year

Mambu Production (Sydney, Australia)
Availability report last 30 days
Availability report current year

Mambu Production (N. Virginia, USA) ? Operational
Mambu Production (Dublin, Ireland) ? Operational
Mambu Production 2 (Dublin, Ireland) ? Operational
Mambu Production (Singapore, Asia) ? Operational
Mambu Production (Sydney, Australia) ? Operational
Mambu Sandbox (N. Virginia, USA) ? Operational
Mambu Sandbox (Dublin, Ireland) ? Operational
Mambu Sandbox 2 (Dublin, Ireland) ? Operational
Mambu Sandbox (Singapore, Asia) ? Operational
Mambu Sandbox (Sydney, Australia) ? Operational
Mambu Production 2 (N. Virginia, USA) ? Operational
Mambu Sandbox 2 (N. Virginia, USA) ? Operational
MPO Operational
MPO Production 2 (Dublin, Ireland) ? Operational
MPO Sandbox 2 (Dublin, Ireland) ? Operational
MPO Production 2 (N. Virginia, USA) ? Operational
MPO Sandbox 2 (N. Virginia, USA) ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
MPO cache system maintenance on Sandbox Apr 21, 2024 07:00-08:00 UTC
Dear customer,

This message is to inform you about a scheduled maintenance for our caching system. This maintenance is necessary to ensure continued performance, stability, and security of the platform.

What to expect:
The maintenance will take place on 21th of April at 07:00 UTC with an estimated duration of an hour.
While we do not anticipate any downtime, there is a slight possibility of brief service interruptions and user session expirations.
We will be taking all necessary precautions to minimize any potential impact on your applications or integrations.

Please reach out if you have any questions or concerns.

Best regards,
Mambu.

Posted on Apr 02, 2024 - 09:22 UTC
Dear customer,

This message is to inform you about a scheduled maintenance for our caching system. This maintenance is necessary to ensure continued performance, stability, and security of the platform.

What to expect:
The maintenance will take place on 12th of May at 07:00 UTC with an estimated duration of an hour.
While we do not anticipate any downtime, there is a slight possibility of brief service interruptions and user session expirations.
We will be taking all necessary precautions to minimize any potential impact on your applications or integrations.

Please reach out if you have any questions or concerns.

Best regards,
Mambu.

Posted on Apr 02, 2024 - 09:33 UTC
Mambu Production (N. Virginia, USA) Latency
Fetching
Mambu Production (Dublin, Ireland) Latency
Fetching
Mambu Production 2 (Dublin, Ireland) Latency
Fetching
Mambu Production (Sydney, Australia) Latency
Fetching
Mambu Production (Singapore, Asia) Latency
Fetching
Mambu Sandbox (N. Virginia, USA) Latency
Fetching
Mambu Sandbox (Dublin, Ireland) Latency
Fetching
Mambu Sandbox 2 (Dublin, Ireland) Latency
Fetching
Mambu Sandbox (Sydney, Australia) Latency
Fetching
Mambu Sandbox (Singapore, Asia) Latency
Fetching
Mambu Production 2 (N. Virginia, USA) Latency
Fetching
Mambu Sandbox 2 (N. Virginia, USA) Latency
Fetching
Past Incidents
Apr 18, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 18, 00:10 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-ireland2 on 17 April 2024 at 19:55 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 19:54 UTC
Apr 17, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 17, 23:03 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-dublin on 17 April 2024 at 19:56 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 19:55 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 17, 14:36 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-sydney on 17 April 2024 at 12:28 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 12:27 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 17, 14:34 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-singapore on 17 April 2024 at 12:28 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 12:27 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 17, 10:27 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-nvirginia on 17 April 2024 at 08:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 08:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 17, 10:27 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-nvirginia2 on 17 April 2024 at 08:32 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 17, 08:31 UTC
Apr 16, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 16, 23:18 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-ireland2 on 16 April 2024 at 20:25 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 16, 20:24 UTC
Apr 15, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 21:27 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-dublin on 15 April 2024 at 19:33 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 19:31 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 16:08 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-nvirginia2 on 15 April 2024 at 14:15 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 14:14 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 14:24 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-sydney on 15 April 2024 at 12:18 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 12:16 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 14:21 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-singapore on 15 April 2024 at 12:18 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 12:17 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 10:01 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-nvirginia on 15 April 2024 at 08:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 08:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 15, 10:01 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-nvirginia2 on 15 April 2024 at 08:31 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-2

Apr 15, 08:30 UTC
Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 11, 09:47 UTC
In progress - We discovered an issue during v9.160.0 release. Please note Mambu is performing a rollback to version v9.159.2 on sand-nvirginia on 11 April 2024 at 08:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 11, 08:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 11, 09:47 UTC
In progress - We discovered an issue during v9.160.0 release. Please note Mambu is performing a rollback to version v9.159.2 on sand-nvirginia2 on 11 April 2024 at 08:32 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 11, 08:31 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 11, 00:19 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on prod-ireland2 on 10 April 2024 at 20:25 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 10, 20:24 UTC
Apr 10, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 10, 21:54 UTC
In progress - We discovered an issue during v9.160.0 release. Please note Mambu is performing a rollback to version v9.159.2 on sand-dublin on 10 April 2024 at 19:40 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 10, 19:39 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 10, 15:40 UTC
In progress - We discovered an issue during v9.160.0-4352846638155e0 release. Please note Mambu is performing a rollback to version v9.159.2 on sand-sydney on 10 April 2024 at 13:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 10, 13:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 10, 15:25 UTC
In progress - We discovered an issue during v9.160.0-4352846638155e0 release. Please note Mambu is performing a rollback to version v9.159.2 on sand-singapore on 10 April 2024 at 13:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 10, 13:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 10, 13:46 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-ireland2 on 10 April 2024 at 10:32 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-159-2

Apr 10, 10:31 UTC
Completed - The scheduled maintenance has been completed.
Apr 10, 11:20 UTC
In progress - Please note Payments is releasing improvements and bug fixes on Sandbox Ireland2 on 10 April 2024 at 10:31 UTC. No downtime is expected. The release notes are available for your review here: https://community.mambu.com/t/payments-release-notes-v1-44-59. Please be informed that for production releases taking place as of August 1st 2023, this maintenance window will not be issued anymore. This is due to the improved stability observed over the last releases which makes this communication obsolete. In the case where you would like to comment on that, please reach out to the product person of contact.
Apr 10, 10:31 UTC
Completed - The scheduled maintenance has been completed.
Apr 10, 10:10 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-ireland2 on 08 April 2024 at 20:34 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 20:33 UTC
Apr 9, 2024

No incidents reported.

Apr 8, 2024
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 8, 22:43 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-dublin on 08 April 2024 at 20:36 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 20:35 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 8, 15:35 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-singapore on 08 April 2024 at 13:30 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 13:29 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 8, 15:04 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-sydney on 08 April 2024 at 13:27 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 13:25 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 8, 12:19 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-nvirginia on 08 April 2024 at 08:36 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 08:35 UTC
Completed - This maintenance is being automatically closed, please refer to the latest status page update
Apr 8, 12:19 UTC
In progress - Please note Mambu is releasing improvements and bug fixes on sand-nvirginia2 on 08 April 2024 at 08:36 UTC. No downtime is expected.
The release notes are available for your review here: https://community.mambu.com/t/mambu-release-notes-v9-160-0

Apr 8, 08:35 UTC
Apr 7, 2024
Completed - The scheduled maintenance has been completed.
Apr 7, 08:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 7, 07:00 UTC
Scheduled - Mambu MYSQL MinorVersion upgrade to 8.0.35 for PRODUCTION MASTER instances.
Mambu is continues release cycle to upgrade existing AWS RDS instance to MYSQL version 8.0.35 (currently 8.0.32).
During this maintenance window Mambu will be upgrading Master instances.
The downtime for a minor version upgrade can last for several minutes. Mambu will be not accessible during the period.
NOTE: this change is backwards compatible.
Thank you for your understanding.

Mar 19, 08:19 UTC
Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.

Apr 4, 2024

No incidents reported.