Mambu is releasing v9.178.3 on prod-singapore from 2025-08-13 12:08 UTC to 2025-08-13 13:59 UTC

Scheduled maintenance CBE Production (Singapore, Asia, AWS)
2025-08-13 12:08 UTC · 1 hour, 51 minutes

Updates

Resolved

The scheduled maintenance has been completed.

August 13, 2025 · 13:59 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on prod-singapore on Wednesday, 13-Aug-25 12:08:00 UTC. No downtime is expected.
The release notes are available for your review here.

August 13, 2025 · 12:08 UTC

← Back