Mambu is releasing v9.179.0 on sand-dublin from 2025-08-18 19:07 UTC to 2025-08-18 20:43 UTC

Scheduled maintenance CBE Sandbox (Dublin, Ireland, AWS)
2025-08-18 19:07 UTC · 1 hour, 35 minutes

Updates

Resolved

The scheduled maintenance has been completed.

August 18, 2025 · 20:43 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-dublin on Monday, 18-Aug-25 19:07:37 UTC. No downtime is expected.
The release notes are available for your review here.

August 18, 2025 · 19:07 UTC

← Back