Planned infrastructure maintenance on Production environment from 2025-09-28 10:00 UTC to 2025-09-28 13:00 UTC

Scheduled maintenance CBE Production (Frankfurt, Europe, Azure)
2025-09-28 10:00 UTC · 3 hours

Updates

Resolved

This maintenance has been concluded as planned.

September 28, 2025 · 13:00 UTC
Started

This maintenance is now starting as planned.

September 28, 2025 · 10:00 UTC
Postponed

Maintenance window has been postponed to 2025-09-28.

September 23, 2025 · 14:58 UTC
Resolved

Planned maintenance is cancelled.

September 21, 2025 · 10:56 UTC
Postponed

Planned maintenance cancelled.

September 21, 2025 · 10:55 UTC
Started

This maintenance is now starting as planned.

September 21, 2025 · 07:00 UTC
Scheduled

Mambu will be performing infrastructure maintenance to enhance storage solution on your production environment. During the change we will be closely monitoring environment to ensure no impact of Mambu application.

September 8, 2025 · 15:12 UTC

← Back