Mambu is releasing v9.180.0 on sand-azureuae from 2025-09-16 13:17 UTC to 2025-09-16 14:16 UTC

Scheduled maintenance CBE Sandbox (UAE, Middle East, Azure)
2025-09-16 13:17 UTC · 58 minutes

Updates

Resolved

The scheduled maintenance has been completed.

September 16, 2025 · 14:16 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-azureuae on Tuesday, 16-Sep-25 13:17:51 UTC. No downtime is expected.
The release notes are available for your review here.

September 16, 2025 · 13:17 UTC

← Back