Mambu is releasing v9.180.0 on sand-sngpr2 from 2025-09-16 13:19 UTC to 2025-09-16 14:24 UTC

Scheduled maintenance CBE Sandbox 2 (Singapore, Asia)
2025-09-16 13:19 UTC · 1 hour, 5 minutes

Updates

Resolved

The scheduled maintenance has been completed.

September 16, 2025 · 14:24 UTC
Update

Please be advised that the latest application update has been temporarily put on hold. Our technical team is currently investigating the situation, and the deployment will be resumed as soon as possible.

September 16, 2025 · 13:55 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-sngpr2 on Tuesday, 16-Sep-25 13:19:25 UTC. No downtime is expected.
The release notes are available for your review here.

September 16, 2025 · 13:19 UTC

← Back