Mambu is releasing v9.181.0 on sand-sngpr2 from 2025-10-09 13:24 UTC to 2025-10-09 14:03 UTC

Scheduled maintenance CBE Sandbox 2 (Singapore, Asia)
2025-10-09 13:24 UTC · 38 minutes

Updates

Resolved

The scheduled maintenance has been completed.

October 9, 2025 · 14:03 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-sngpr2 on Thursday, 09-Oct-25 13:24:52 UTC. No downtime is expected.
The release notes are available for your review here.

October 9, 2025 · 13:24 UTC

← Back