Mambu is releasing v9.181.0 on prod-sydney from 2025-10-15 18:20 UTC to 2025-10-15 20:36 UTC

Scheduled maintenance CBE Production (Sydney, Australia, AWS)
2025-10-15 18:20 UTC · 2 hours, 16 minutes

Updates

Resolved

The scheduled maintenance has been completed.

October 15, 2025 · 20:36 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on prod-sydney on Wednesday, 15-Oct-25 18:20:01 UTC. No downtime is expected.
The release notes are available for your review here.

October 15, 2025 · 18:20 UTC

← Back