Mambu is releasing v9.182.1 on prod-sydney from 2025-11-03 18:16 UTC to 2025-11-03 20:08 UTC

Scheduled maintenance CBE Production (Sydney, Australia, AWS)
2025-11-03 18:16 UTC · 1 hour, 52 minutes

Updates

Resolved

The scheduled maintenance has been completed.

November 3, 2025 · 20:08 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on prod-sydney on Monday, 03-Nov-25 18:16:02 UTC. No downtime is expected.
The release notes are available for your review here.

November 3, 2025 · 18:16 UTC

← Back