Mambu is releasing v9.183.5 on prod-zurich from 2025-12-02 18:17 UTC to 2025-12-02 19:22 UTC

Scheduled maintenance CBE Production (Zurich, Europe)
2025-12-02 18:17 UTC · 1 hour, 4 minutes

Updates

Resolved

The scheduled maintenance has been completed.

December 2, 2025 · 19:22 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on prod-zurich on Tuesday, 02-Dec-25 18:17:50 UTC. No downtime is expected.
The release notes are available for your review here.

December 2, 2025 · 18:17 UTC

← Back