Mambu is releasing v9.185.2 on sand-nvirginia2 from 2026-01-19 08:47 UTC to 2026-01-19 11:51 UTC

Scheduled maintenance CBE Sandbox 2 (N. Virginia, USA, AWS)
2026-01-19 08:47 UTC · 3 hours, 3 minutes

Updates

Resolved

The scheduled maintenance has been completed.

January 19, 2026 · 11:51 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-nvirginia2 on Monday, 19-Jan-26 08:47:56 UTC. No downtime is expected.
The release notes are available for your review here.

January 19, 2026 · 08:47 UTC

← Back