Mambu is releasing v9.185.2 on sand-azureuae from 2026-01-19 13:25 UTC to 2026-01-19 14:15 UTC

Scheduled maintenance CBE Sandbox (UAE, Middle East, Azure)
2026-01-19 13:25 UTC · 50 minutes

Updates

Resolved

The scheduled maintenance has been completed.

January 19, 2026 · 14:15 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-azureuae on Monday, 19-Jan-26 13:25:15 UTC. No downtime is expected.
The release notes are available for your review here.

January 19, 2026 · 13:25 UTC

← Back