Mambu is releasing v9.185.3 on sand-montreal from 2026-01-21 08:30 UTC to 2026-01-21 09:24 UTC

Scheduled maintenance CBE Sandbox (Montreal, Canada)
2026-01-21 08:30 UTC · 53 minutes

Updates

Resolved

The scheduled maintenance has been completed.

January 21, 2026 · 09:24 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-montreal on Wednesday, 21-Jan-26 08:30:54 UTC. No downtime is expected.
The release notes are available for your review here.

January 21, 2026 · 08:30 UTC

← Back