Mambu is releasing v9.185.3 on sand-nvirginia from 2026-01-22 00:11 UTC to 2026-01-22 01:18 UTC

Scheduled maintenance CBE Sandbox (N. Virginia, USA), AWS
2026-01-22 00:11 UTC · 1 hour, 6 minutes

Updates

Resolved

The scheduled maintenance has been completed.

January 22, 2026 · 01:18 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-nvirginia on Thursday, 22-Jan-26 00:11:38 UTC. No downtime is expected.
The release notes are available for your review here.

January 22, 2026 · 00:11 UTC

← Back