Mambu is releasing v9.186.0 on prod-montreal from 2026-02-03 08:04 UTC to 2026-02-03 08:39 UTC

Scheduled maintenance CBE Production (Montreal, Canada)
2026-02-03 08:04 UTC · 35 minutes

Updates

Resolved

The scheduled maintenance has been completed.

February 3, 2026 · 08:39 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on prod-montreal on Tuesday, 03-Feb-26 08:04:49 UTC. No downtime is expected.
The release notes are available for your review here.

February 3, 2026 · 08:04 UTC

← Back