Mambu is releasing v9.187.1 on sand-nvirginia from 2026-02-11 00:04 UTC to 2026-02-11 01:09 UTC

Scheduled maintenance CBE Sandbox (N. Virginia, USA), AWS
2026-02-11 00:04 UTC · 1 hour, 4 minutes

Updates

Resolved

The scheduled maintenance has been completed.

February 11, 2026 · 01:09 UTC
Monitoring

Please note Mambu is releasing improvements and bug fixes on sand-nvirginia on Wednesday, 11-Feb-26 00:04:56 UTC. No downtime is expected.
The release notes are available for your review here.

February 11, 2026 · 00:04 UTC

← Back