Mambu is rolling back v9.187.2 --> v9.186.2 on prod-sydney from 2026-03-04 08:49 UTC to 2026-03-04 10:58 UTC

Scheduled maintenance CBE Production (Sydney, Australia, AWS)
2026-03-04 08:49 UTC · 2 hours, 9 minutes

Updates

Resolved

The scheduled maintenance has been completed.

March 4, 2026 · 10:58 UTC
Monitoring

We discovered an issue during v9.187.2 release.
Please note Mambu is performing a rollback to version prod-sydney on Wednesday, 04-Mar-26 08:49:09 UTC. No significant performance impact is expected. However, users who are actively using the Mambu UI may temporarily see a message prompting them to refresh their browser — “Mambu has been updated: please refresh your browser to see the latest changes.”

If this occurs, please wait until the Mambu Health Page confirms that the rollback has been successfully completed. Once a success notification is posted, verify that the UI is accessible. If the issue persists after confirmation, please clear your browser cache and refresh the page to ensure you are connected to the latest version.

We appreciate your patience and understanding as we work to restore full functionality as quickly as possible. The release notes are available for your review here.

March 4, 2026 · 08:49 UTC

← Back