Mambu Audit Trail is currently down, no data is stored.

Incident Report for Mambu

Resolved

Services have been restored following a scaling event and other troubleshooting actions, completed in collaboration with AWS. This is the final update regarding this situation. Thank you for your understanding and cooperation during this incident.
Posted Jun 23, 2025 - 15:00 UTC

Identified

Hello,

Please note we have observed alerts indicating audit trail is down and no new data is being stored as of approx. 06:25 UTC.

We have engaged AWS support who have identified a hardware issue which is in the process of being remediated - we will maintain close contact with AWS until this is resolved and share further updates as appropriate.
Posted Jun 12, 2025 - 07:33 UTC
This incident affected: Mambu Production 2 (N. Virginia, USA).